Fonts not displaying correctly

Post here any questions/suggestions you have about novaPDF SDK or novaPDF OEM.
byardis
Posts: 1
Joined: Wed Jun 15, 2011 2:20 pm

Fonts not displaying correctly

Postby byardis » Wed Jun 15, 2011 2:31 pm

I have a client who has two PDF files that they want to combine into one. Our application automates Acrobat and prints the two PDFs to the novaPDF SDK printer driver to create the resulting file. These same files work fine on all our development machines, but on the clients machine, the fonts are not displaying correctly.

The original PDF files have the following fonts contained:
Helvetica
Helvetica Bold
MyriadPro

When generating the PDF, I set the option to embed fonts. The resulting PDF file has the following fonts contained:
Helvetica (Embedded Subset)
Helvetica Bold (Embedded Subset)
MyriadPro (Embedded Subset)

But the font is displaying garbled in the resulting PDF. I assume that the machine does not have one of the fonts install, but don't understand why it still says that the correct fonts are embedded. Wouldn't it have substituted the font and embedded whichever one it is substituted with?

Any suggestions on how I can get this PDF to render correctly?

Thanks,
Brent

Support
Posts: 223
Joined: Wed Dec 16, 2009 12:46 pm
Location: Cluj-Napoca, Romania
Contact:

Re: Fonts not displaying correctly

Postby Support » Thu Jun 16, 2011 6:17 am

Hello,

Please send us the original PDFs that were used for merging along with the resulting PDF with the fonts issue at our support team at support@novaPDF.com for further testing and troubleshooting.

Thank you.


Return to “Developer Tools”