CreateDC fails

Have questions about novaPDF (desktop or server), or having problems using it? Ask here for help.
Post Reply
kpulley@dentrix.com
Posts: 1
Joined: Tue May 10, 2011 7:35 pm

CreateDC fails

Post by kpulley@dentrix.com » Tue May 10, 2011 7:49 pm

I have a Legacy system (c++) that calls CreateDC() to get the NovaPDF printerDC.
everything worked fine when the code was compiled in Microsoft VS 2008.

after I upgraded to VS 2010, the first time CreateDC() is run it will cause an error "Application has stopped working." On 64-bit machines the error will be "Print driver host for 32bit app. has stopped working."
This does not seem to happen on all machines but it happens on about half of them.

Again, this only happens the first time the application is run, after that it seems to run fine.

my customers complain about this error. What can I do.

I did some more testing. when the printer driver is installed and Notepad.exe prints to NovaPDF the same error message happens.
(and will work on the 2nd try)

Support
Posts: 223
Joined: Wed Dec 16, 2009 12:46 pm

Re: CreateDC fails

Post by Support » Wed May 11, 2011 6:57 am

Hello,

We will troubleshoot this issue further to find the cause of the error and implement a fix.

Thank you for reporting the problem.

Post Reply